Delphi 11 app in Android Play Store shows warning: Non-SDK API

  

The "Pre-launch report overview" in "Google Play Console" shows this warning:
Type:
Non-SDK API

API:
Landroid/view/MotionEvent;-><init>()V

Stack trace:
StrictMode policy violation: android.os.strictmode.NonSdkApiUsedViolation: Landroid/view/MotionEvent;-><init>()V

This error has previously been fixed in Delphi 10.3, see https://quality.embarcadero.com/browse/RSP-22046
but its now back in Delphi 11?
The solutions I can find on Google is about setting a newer targetSdkVersion in the AndroidManifest.xml
However, we already set it to API level 30, as it is required to deploy to the new Play Store. In AndroidManifest.xml we have:
<uses-sdk android:minSdkVersion="23" android:targetSdkVersion="30" />

Anyone having seen this error lately with a "Delphi 11" app on Play Store? – and eventually having found a solution?

Comments are closed.