How to include androidx.preference:preference:1.1.1 in my android project

  

I try to add androidx.preference:preference:1.1.1 in my project and when I look the dependencies of androidx.preference:preference:1.1.1 I found this :
\— androidx.preference:preference:1.1.1
+— androidx.appcompat:appcompat:1.1.0
| +— androidx.annotation:annotation:1.1.0
| +— androidx.core:core:1.1.0
| | +— androidx.annotation:annotation:1.1.0
| | +— androidx.lifecycle:lifecycle-runtime:2.0.0 -> 2.2.0
| | | +— androidx.lifecycle:lifecycle-common:2.2.0
| | | | \— androidx.annotation:annotation:1.1.0
| | | +— androidx.arch.core:core-common:2.1.0
| | | | \— androidx.annotation:annotation:1.1.0
| | | \— androidx.annotation:annotation:1.1.0
| | +— androidx.versionedparcelable:versionedparcelable:1.1.0
| | | +— androidx.annotation:annotation:1.1.0
| | | \— androidx.collection:collection:1.0.0 -> 1.1.0
| | | \— androidx.annotation:annotation:1.1.0
| | \— androidx.collection:collection:1.0.0 -> 1.1.0 (*)
| +— androidx.cursoradapter:cursoradapter:1.0.0
| | \— androidx.annotation:annotation:1.0.0 -> 1.1.0
| +— androidx.fragment:fragment:1.1.0 -> 1.2.4
| | +— androidx.annotation:annotation:1.1.0
| | +— androidx.core:core:1.1.0 (*)
| | +— androidx.collection:collection:1.1.0 (*)
| | +— androidx.viewpager:viewpager:1.0.0
| | | +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | | +— androidx.core:core:1.0.0 -> 1.1.0 (*)
| | | \— androidx.customview:customview:1.0.0
| | | +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | | \— androidx.core:core:1.0.0 -> 1.1.0 (*)
| | +— androidx.loader:loader:1.0.0
| | | +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | | +— androidx.core:core:1.0.0 -> 1.1.0 (*)
| | | +— androidx.lifecycle:lifecycle-livedata:2.0.0
| | | | +— androidx.arch.core:core-runtime:2.0.0 -> 2.1.0
| | | | | +— androidx.annotation:annotation:1.1.0
| | | | | \— androidx.arch.core:core-common:[2.1.0] -> 2.1.0 (*)
| | | | +— androidx.lifecycle:lifecycle-livedata-core:2.0.0 -> 2.2.0
| | | | | +— androidx.lifecycle:lifecycle-common:2.2.0 (*)
| | | | | +— androidx.arch.core:core-common:2.1.0 (*)
| | | | | \— androidx.arch.core:core-runtime:2.1.0 (*)
| | | | \— androidx.arch.core:core-common:2.0.0 -> 2.1.0 (*)
| | | \— androidx.lifecycle:lifecycle-viewmodel:2.0.0 -> 2.2.0
| | | \— androidx.annotation:annotation:1.1.0
| | +— androidx.activity:activity:1.1.0
| | | +— androidx.annotation:annotation:1.1.0
| | | +— androidx.core:core:1.1.0 (*)
| | | +— androidx.lifecycle:lifecycle-runtime:2.2.0 (*)
| | | +— androidx.lifecycle:lifecycle-viewmodel:2.2.0 (*)
| | | +— androidx.savedstate:savedstate:1.0.0
| | | | +— androidx.annotation:annotation:1.1.0
| | | | +— androidx.arch.core:core-common:2.0.1 -> 2.1.0 (*)
| | | | \— androidx.lifecycle:lifecycle-common:2.0.0 -> 2.2.0 (*)
| | | \— androidx.lifecycle:lifecycle-viewmodel-savedstate:1.0.0 -> 2.2.0
| | | +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | | +— androidx.savedstate:savedstate:1.0.0 (*)
| | | +— androidx.lifecycle:lifecycle-livedata-core:2.2.0 (*)
| | | \— androidx.lifecycle:lifecycle-viewmodel:2.2.0 (*)
| | +— androidx.lifecycle:lifecycle-livedata-core:2.2.0 (*)
| | +— androidx.lifecycle:lifecycle-viewmodel:2.2.0 (*)
| | \— androidx.lifecycle:lifecycle-viewmodel-savedstate:2.2.0 (*)
| +— androidx.appcompat:appcompat-resources:1.1.0
| | +— androidx.annotation:annotation:1.1.0
| | +— androidx.core:core:1.0.1 -> 1.1.0 (*)
| | +— androidx.vectordrawable:vectordrawable:1.1.0
| | | +— androidx.annotation:annotation:1.1.0
| | | +— androidx.core:core:1.1.0 (*)
| | | \— androidx.collection:collection:1.1.0 (*)
| | +— androidx.vectordrawable:vectordrawable-animated:1.1.0
| | | +— androidx.vectordrawable:vectordrawable:1.1.0 (*)
| | | +— androidx.interpolator:interpolator:1.0.0
| | | | \— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | | \— androidx.collection:collection:1.1.0 (*)
| | \— androidx.collection:collection:1.0.0 -> 1.1.0 (*)
| +— androidx.drawerlayout:drawerlayout:1.0.0
| | +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | +— androidx.core:core:1.0.0 -> 1.1.0 (*)
| | \— androidx.customview:customview:1.0.0 (*)
| \— androidx.collection:collection:1.0.0 -> 1.1.0 (*)
+— androidx.core:core:1.1.0 (*)
+— androidx.fragment:fragment:1.2.4 (*)
+— androidx.recyclerview:recyclerview:1.0.0
| +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| +— androidx.core:core:1.0.0 -> 1.1.0 (*)
| \— androidx.legacy:legacy-support-core-ui:1.0.0
| +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| +— androidx.core:core:1.0.0 -> 1.1.0 (*)
| +— androidx.legacy:legacy-support-core-utils:1.0.0
| | +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | +— androidx.core:core:1.0.0 -> 1.1.0 (*)
| | +— androidx.documentfile:documentfile:1.0.0
| | | \— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | +— androidx.loader:loader:1.0.0 (*)
| | +— androidx.localbroadcastmanager:localbroadcastmanager:1.0.0
| | | \— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | \— androidx.print:print:1.0.0
| | \— androidx.annotation:annotation:1.0.0 -> 1.1.0
| +— androidx.customview:customview:1.0.0 (*)
| +— androidx.viewpager:viewpager:1.0.0 (*)
| +— androidx.coordinatorlayout:coordinatorlayout:1.0.0
| | +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | +— androidx.core:core:1.0.0 -> 1.1.0 (*)
| | \— androidx.customview:customview:1.0.0 (*)
| +— androidx.drawerlayout:drawerlayout:1.0.0 (*)
| +— androidx.slidingpanelayout:slidingpanelayout:1.0.0
| | +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | +— androidx.core:core:1.0.0 -> 1.1.0 (*)
| | \— androidx.customview:customview:1.0.0 (*)
| +— androidx.interpolator:interpolator:1.0.0 (*)
| +— androidx.swiperefreshlayout:swiperefreshlayout:1.0.0
| | +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | +— androidx.core:core:1.0.0 -> 1.1.0 (*)
| | \— androidx.interpolator:interpolator:1.0.0 (*)
| +— androidx.asynclayoutinflater:asynclayoutinflater:1.0.0
| | +— androidx.annotation:annotation:1.0.0 -> 1.1.0
| | \— androidx.core:core:1.0.0 -> 1.1.0 (*)
| \— androidx.cursoradapter:cursoradapter:1.0.0 (*)
+— androidx.annotation:annotation:1.1.0
\— androidx.collection:collection:1.0.0 -> 1.1.0 (*)

So it’s terrific to add all those aar/jar manually 🙁
How can I do ?

Comments are closed.