Uncaught translation error: com.android.dx.cf.code.SimException requires –min-sdk-version >= 26

  

When i try in a blank delphi project to add this library :

https://bintray.com/google/webrtc/download_file?file_path=org%2Fwebrtc%2Fgoogle-webrtc%2F1.0.25331%2Fgoogle-webrtc-1.0.25331.aar

Then, when i compile the app and when delphi execute

“C:\SDKs\android-sdk-windows\build-tools\28.0.3\dx.bat” –dex
–output=”C:\FmxLiveChatVideo_source\Android\Debug\libwebrtc-dexed.jar”
“C:\lib\jar\org.webrtc\libwebrtc.jar”

I receive this error

Uncaught translation error: com.android.dx.cf.code.SimException: ERROR
in org.webrtc.Camera1Session.listenForTextureFrames:()V: invalid
opcode ba – invokedynamic requires –min-sdk-version >= 26 (currently
13)

Outside delphi, from the command line, if i add –min-sdk-version=26 to the line

“C:\SDKs\android-sdk-windows\build-tools\28.0.3\dx.bat” –dex
–output=”C:\FmxLiveChatVideo_source\Android\Debug\libwebrtc-dexed.jar”
“C:\lib\jar\org.webrtc\libwebrtc.jar”

then it’s compile BUT now of course i can not deploy anymore the app to target lower than api 26 🙁

As I understand, it’s connected to the java version. Android in the past only supported Java code up to version 1.7 and seam we need 1.8. No idea what i can do 🙁

Comments are closed.