undock/split keyboard on iPad Pro in Firemonkey Apps

  

It is not possible to undock/split the keyboard on an iPad Pro (10.5inch, A1701) device with iOS 11 within in a Delphi/Firemonkey app. In other apps (like Safari) undocking is no problem.

Is there a delphi project setting I can change this or another solution to solve this behaviour?

How to reproduce:

Create a new Firemonkey application in Delphi
Drop a TEdit or a TMemo on the Mainform
Compile the project (as iOS 64bit) and run it an an iPad Pro 10.5″ with iOS 11
Try to split/undock the keyboard if you select the TEdit or the TMemo

What I tried so far:

Tried with Delphi 10.1 Berlin Update 2 Ent.

XCode 8.2 and iOS SDK 10.2

Tried with Delphi 10.2 Tokyo Update 2 Ent.

XCode 8.2 and iOS SDK 10.2
XCode 9.2 and iOS SDK 11.2

As counter example I created a Hello World App in Xcode 9.2 with a Label and an Entry on the storyboard.

Here is a screenshot of the iPad Settings app where undock/slpit is available:

Here is a screenshot of the simple test-app; I was not able to create a screenshot with the selected keyboard symbol at the right corner:

You can’t easily see it but the keyboard without the split/undock feature from the Firemonkey app is higher than the other one.

Is there a way to enable the undock- and/or splitmode for the keyboard in a Firemonkey app for iOS 11 on an iPad Pro Device?

It may be related to this “Old virtual keyboard on iPad Pro” question.

Comments are closed.