Firemonkey Delphi XE7 app does not work in Lollipop

  

Please I need your help with a problem with my android app developed in Delphi XE7 Upd1 Firemonkey, I’m trying to find a solution to the problem below of this lines from two days ago that it drives me crazy and I’m giving up;

Situation: My app is working fine in devices with Android KK 4.x, it developed in Delphi XE7 Upd1, recently, in the enterprise that I work, changed all the devices with a new ones with Lollipop 5.0.

Problem: When I installed the app to the new devices, doesn’t work anymore, ANRs, unexpected closes, freezes, sometimes does not starts…
I’ve tried with many tests but none of them works;

I installed the hotfix for FireMonkey apps on Android 5.0 (http://cc.embarcadero.com/item/30110), my app uses some bitmaps, and problem continues.
I deleted all bitmaps in the app and problem continues.
All packages in SDK Manager are up to date and problem continues.
By testing, I installed the MultiView and TabSliding basic project samples of Rad Studio 15.0 in the new devices, and oohhh, ANR still continues 🙁
Finally, I installed the TabSliding basic project sample of Rad Studio 17.0 (Delphi DX 10) and works fine, but if open a TabSliding basic sample project of Rad Studio 15.0 in Delphi DX 10 and deploy to the new device, ohhhhhh nooooooo, ANR appears.

Does anybody experimented this problem?, is there any solution for the Delphi XE7 Firemonkey apps work fine in Lollipop?

Please I need your help, two days with a few hours of sleep and I don’t know to do to solve this problem.

Many thanks.

P.S. Sorry for my bad English.

Comments are closed.